Issues with secure (HTTPS) access to sites
Incident Report for TwentyThree
Resolved
The problem has been identified and rectified. Earlier today, a problem was detected where some SSL certificates were not being validated correctly under certain circumstances. The problem affected a subset of our customers covered by GlobalSign-issues certificates, and more information about the root cause can be found on GlobalSign's status page at https://www.globalsign.com/en/customer-revocation-error/.

Even after the resolution, caching may still affect delivery. If you are experiencing any SSL/HTTPS connection issues on TwentyThree, please contact the support team standing by to help at support@twentythree.net.
Posted Oct 13, 2016 - 23:43 CEST
Identified
A solution has been found and is being rolled out across all servers. An update will follow once we have confirmed that all issues have been fixed.
Posted Oct 13, 2016 - 18:35 CEST
Investigating
Some sites are currently experiencing errors blocking access to sites through HTTPS. Currently only Google Chrome and Internet Explorer seems to be affected (Firefox and Safari work as expected). We are investigating and will update as we know more.
Posted Oct 13, 2016 - 14:22 CEST