Degraded performance on the TwentyThree Platform
Incident Report for TwentyThree
Resolved
This incident has been resolved.
Posted Sep 21, 2018 - 18:39 CEST
Investigating
We've seen periods of slow responses from the core web platform over the past hours. We have identified the issue and are monitoring response times.
Posted Sep 21, 2018 - 14:02 CEST
This incident affected: TwentyThree Platform.