Degraded performance
Incident Report for TwentyThree
Resolved
We have identified and fixed the issue and latency should be back to normal. As always, please get in touch with support if you experience any issues.
Posted Sep 27, 2017 - 11:19 CEST
Investigating
We are currently experiencing increased latency on requests. We are working on mitigating the issue and returning to normal operation as soon as possible.
Posted Sep 27, 2017 - 11:01 CEST